Give Proper Names to Your Variables

This tip submitted by Maragato on 2005-01-13 19:14:51. It has been viewed 22571 times.
Rating of 5.6 with 104 votes



Don't call variables a, b or d. Give proper names like bitCounter or bitcounter. Also use the same naming conventions consistently and consider choosing different styles for each part of your program. For instance, you might make FooDoo the name of a class, fooDoo the name of a function, and foo_doo the name of a variable. This can make it easier to spot simple mistakes like leaving off parens for a function call or using the wrong capitalization for a class or struct: if you consistently use the same naming conventions, it becomes very easy to remember the way you capitalized names.



More tips

Help your fellow programmers! Add a tip!